PGP Key Generator doesnt respect RFC4880
Closed, InvalidPublic

Description

https://tools.ietf.org/html/rfc4880#section-5.11

It says there is no restriction on the content of the UserID.

I use GnuPG 2.1.15 here on Ubuntu it doesnt let me create a key with anything other than a valid email address.

or am i missing something here?

thanks

Details

Version
2.1.15
lovetox created this task.Jul 1 2017, 1:06 AM
gouttegd edited projects, added Not A Bug; removed Bug Report.Jul 1 2017, 1:47 AM
gouttegd closed this task as Invalid.
gouttegd added a subscriber: gouttegd.

or am i missing something here?

You're missing the --allow-freeform-uid option, which allows you to create a key with the UserID you want even if it does not conform to the "Real Name (Comment) <Email>" convention.

You can also use the --rfc4880 flag, which activates several compliance-related options (including the --allow-freeform-uid flag).