pinentry no longer floating
Closed, ResolvedPublic

Description

Using DWM window manager, the gnupg pinentry dialog is no longer floating. Instead it gets tiled like a normal window. DWM floats all dialog windows by default, so I'm guessing something changed in pinentry so the window is no longer identified as a "dialog".

I can isolate this change between 2.1.21 and 2.1.23.

uname -a: Linux desktop-arch 4.12.8-1-ARCH #1 SMP PREEMPT Thu Aug 17 08:37:20 CEST 2017 x86_64 GNU/Linux

Details

Version
2.1.23
rcorre created this task.Aug 20 2017, 10:36 PM

I suspect this is a duplicate of T3253, where the same behavior (non-floating pinentry dialog) was observed under both the i3 and the Awesome tiling window managers. This bug has been fixed in master and the fix will be part of the upcoming pinentry-1.1.0 release.

What’s the version of pinentry (pinentry --version) ? Any chance you could test the current master branch under DWM?

justus triaged this task as Low priority.Aug 21 2017, 11:26 AM

I just realized that my fix for T3253 was incomplete, it only works if grabbing is enabled. With GnuPG Agent not requesting grabbing by default since 2.1.23, that would make the fix useless in the default configuration. Coming with a new patch soon...

Sorry for the delayed response. I am in fact on pinentry 1.0.0, and haven't tested master yet. Looking forward to the patch!

gouttegd closed this task as Resolved.Aug 25 2017, 3:54 PM
gouttegd claimed this task.

OK, thanks for the info.

Meanwhile I did some tests under dwm-6.1, and I confirm it looks like the same issue as T3253, which is now (really) fixed in master. Therefore I’m closing here.

If you test with master yourself and find out you still experience the problem, feel free to re-open as that would indicate there's another issue at hand.