GpgOL: Outlook contact groups are not supported
Closed, ResolvedPublic

Description

Create a group in the Address book. Encrypt to that group.

-> Mail will only be encrypted to your own ( the senders ) key.

The problem is that GpgOL does not find the recipients and thinks that the sender is the only recipient.

06:24:19/9956/oomhelp.cpp:get_oom_object: looking for 2FEAEB10->`Recipients'
06:24:19/9956/oomhelp.cpp:get_oom_object: Object: 2FEAEB10 released ref: 2 
06:24:19/9956/oomhelp.cpp:get_oom_object: Object: 0414FFE8 released ref: 1 
06:24:19/9956/oomhelp.cpp:get_oom_object:         got 0414FFE8
06:24:19/9956/oomhelp.cpp:get_oom_object: looking for 0414FFE8->`Item(1)'
06:24:19/9956/oomhelp.cpp:get_oom_object: Object: 0414FFE8 released ref: 1 
06:24:19/9956/oomhelp.cpp:get_oom_object: Object: 0414F960 released ref: 1 
06:24:19/9956/oomhelp.cpp:get_oom_object:         got 0414F960
06:24:19/9956/oomhelp.cpp:get_pa_variant: Looking up property: http://schemas.microsoft.com/mapi/proptag/0x39FE001E;
06:24:19/9956/oomhelp.cpp:get_oom_object: looking for 0414F960->`PropertyAccessor'
06:24:19/9956/oomhelp.cpp:get_oom_object: Object: 0414F960 released ref: 1 
06:24:19/9956/oomhelp.cpp:get_oom_object: Object: 04150250 released ref: 1 
06:24:19/9956/oomhelp.cpp:get_oom_object:         got 04150250
06:24:19/9956/oomhelp.cpp:get_pa_variant: Object: 04150250 released ref: 0 
06:24:19/9956/oomhelp.cpp:get_pa_variant: error: invoking GetProperty p=00000000 vt=0 hr=0x80020009 argErr=0x0
06:24:19/9956/oomhelp.cpp:dump_excepinfo: Exception: 
              wCode: 0x1000
              wReserved: 0x0
              source: Microsoft Outlook
              desc: The property "http://schemas.microsoft.com/mapi/proptag/0x39FE001E" is unknown or cannot be found.
              help: null
              helpCtx: 0x0
              deferredFill: 00000000
              scode: 0x8004010f
06:24:19/9956/oomhelp.cpp:get_oom_object: looking for 0414F960->`AddressEntry'
06:24:19/9956/oomhelp.cpp:get_oom_object: Object: 0414F960 released ref: 1 
06:24:19/9956/oomhelp.cpp:get_oom_object: Object: 04150250 released ref: 1 
06:24:19/9956/oomhelp.cpp:get_oom_object:         got 04150250
06:24:19/9956/oomhelp.cpp:get_pa_variant: Looking up property: http://schemas.microsoft.com/mapi/proptag/0x800F101E;
06:24:19/9956/oomhelp.cpp:get_oom_object: looking for 04150250->`PropertyAccessor'
06:24:19/9956/oomhelp.cpp:get_oom_object: Object: 04150250 released ref: 1 
06:24:19/9956/oomhelp.cpp:get_oom_object: Object: 0414FF38 released ref: 1 
06:24:19/9956/oomhelp.cpp:get_oom_object:         got 0414FF38
06:24:19/9956/oomhelp.cpp:get_pa_variant: Object: 0414FF38 released ref: 0 
06:24:19/9956/oomhelp.cpp:get_pa_variant: error: invoking GetProperty p=00000000 vt=0 hr=0x80020009 argErr=0x0
06:24:19/9956/oomhelp.cpp:dump_excepinfo: Exception: 
              wCode: 0x1000
              wReserved: 0x0
              source: Microsoft Outlook
              desc: The property "http://schemas.microsoft.com/mapi/proptag/0x800F101E" is unknown or cannot be found.
              help: null
              helpCtx: 0x0
              deferredFill: 00000000
              scode: 0x8004010f
06:24:19/9956/oomhelp.cpp:get_recipient_addr_fallbacks: Failed AB_PROXY lookup.
06:24:19/9956/oomhelp.cpp:get_oom_object: looking for 04150250->`GetExchangeUser'
06:24:19/9956/oomhelp.cpp:get_oom_object: no object
06:24:19/9956/oomhelp.cpp:get_recipient_addr_fallbacks: Object: 04150250 released ref: 1 
06:24:19/9956/oomhelp.cpp:get_recipient_addr_fallbacks: Failed to find ExchangeUser
06:24:19/9956/oomhelp.cpp:get_oom_recipients: Object: 0414F960 released ref: 0 
06:24:19/9956/oomhelp.cpp:get_oom_recipients: Failed to look up Address probably EX addr is returned

Prio High because although this is basically a "missing feature" we need to at least show a warning / error in such a case and don't just send out mails that can't be decrypted by the receiver.

aheinecke removed a parent task: T4029: Gpg4win 3.1.3.
aheinecke changed the task status from Open to Testing.

Works for me now.

Should also work with exchange but I have not tested that yet.

aheinecke closed this task as Resolved.Sep 4 2018, 9:22 AM

Gpg4win-3.1.3 was released.