GPGME: sharing C compiler configuration with SWIG for generated bindings
Closed, ResolvedPublic

Description

Under some, but not necessarily all circumstances, configure parameters used to generate make files with GPGME may not be honoured by SWIG when compiling language bindings depending on a variety of factors.

BenM created this task.Jul 23 2018, 9:40 AM
BenM added a comment.Aug 10 2018, 7:08 AM

Discussion on the #python IRC channel last night with another experienced SWIG developer (of a proprietary and unnamed software project) has provided ass itional evidence supporting the theory that the cause of the problems with getting the bindings to run on Windows systems is indeed directly caused by the fact that Windows users are compiling GPGME and the bindings with a different compiler and runtime than those used to compile whichever version of Python they have obtained from elsewhere.

In the case of that projectthey were subsequently able to get it to work with their Windows users by means of the simple expedient of embedding the Python interpreter in their project. Unfortunately that course is not open to us and we will need to find some other means of making the bindings work on Windows.

This will almost certainly require producing prebuilt versions compiled with with the same version(s) of MS Visual Studio used by the Python developers to build the versions of Python available for download on the Python website. Even so, that kind of solution will very likely be limited to official, stable Python releases only,

BenM closed this task as Resolved.Dec 10 2018, 6:15 AM

See T3505 for more in depth coverage of this issue. Essentially this is a duplicate under a slightly altered POV.