Kleopatra / gpg4win Office Outlook plugin - Office Outlook 2010 crash if trying to send an encrypted message to yourself
Open, NormalPublic

Description

Symptom:
Outlook crash immediately with an error message <...gpg4win does not operate correctly...Outlook will close automatically...>.
After re-start of Outlook the YOURSELF addressed encrypted message sent out correctly over the Exchange server.

Settings:
Encrypt and Sign an outgoing message with BCC=YOURSELF

Environment:
Windows 7 Professional SP1, EN
Office Outlook 2010 Professional SP2, DE
Exchange Server 2007 installed on Windows Server Enterprise 2008 SP2, EN

Details

Version
3.1.4-gpg4win-3.1.5.5.43.0, Gpg4win
aheinecke edited projects, added gpgol, gpg4win; removed kleopatra.Wed, Nov 14, 12:54 PM
aheinecke triaged this task as Normal priority.
aheinecke added a subscriber: aheinecke.

Thanks for reporting your problem. We are highly interested in any crash. But please note that our minimum supported Exchange Version is 2010 because 2007 has reached end of life in april 2017. So I cannot test with that Server.

I cannot reproduce your problem neither with Outlook 2010 or Outlook 2016

Here is what I tried (I also tried some more variations):

Could you please go into GpgOL Options and under Debugging enable logging with the level "+call tracing". Then reproduce the crash and attach the log here. Also please let me know the exact error message. I could not find "gpg4win does not operate correctly" in our source code.

Thanks!

Thank you very much for the quick response and try-out in detail!

I couldn't reproduce the exact problem too while using "New EMail". The reported crash occurs while "Reply" with several encrypted messages sent in the past also as "Reply".
It seems that this issue is a sporadic error?
I need some more time for a closer investigation and do some more tests with Exchange Server 2007.
I switched ON the debug logging as requested and wait for the next crash and error message now.

Regards

.