"load-extension idea" lets gnupg.exe search C:\lib\gnupg\idea
Closed, ResolvedPublic

Description

Environment

Windows 2000

Description

gnupg is installed in %ProgramFiles%\GNU\GnuPG.
The configuration is stored in "%Userprofile%\Application Data\GnuPG\".
I needed IDEA, so I added the line "load-extension idea" to the gnupg.conf, and placed the IDEA.DLL in the installation directory of gnupg.exe, just beside ICONV.DLL and the other *.EXE.
Now every call to gnupg gives:

gpg: LoadLibrary failed: Das System kann die angegebene Datei nicht finden.

gpg: invalid module `c:\lib\gnupg\idea': Das angegebene Modul wurde nicht gefunden.

How To Repeat

See description

Fix

Don't use ANY hardcoded paths under Windows.
Use either paths relative to the installation directory, or just ".", i.e. the installation directory, as with ICONV.DLL

dshaw added a subscriber: dshaw.Aug 5 2005, 5:31 AM

Dupe of 508

dshaw closed this task as Resolved.Aug 5 2005, 5:31 AM