incorrect interpretation of receiver
Closed, InvalidPublic

Description

i just want to construct a key for the uid

b100191

this works:
heiko@goja:~/tmp> gpg --homedir . -a --list-keys
pub 1024D/0564B63A 2009-08-26
uid b1000191
sub 1024g/EF24149F 2009-08-26

the key is in place.
export of this key only works with:
gpg --homedir . -a --export -r b100191
not with:
gpg --homedir . -a --export b100191

encryption of some text doesn't work at all:
gpg --homedir . --encrypt test.txt -r b1000191

but the key stuff is ok encryption with
gpg --homedir . --encrypt test.txt -r 0564B63A
works fine.

this is very strange :-(
if i use another value for uid (b10001910) all things are fine...

it was testet with gpg version 1.4.5 an 2.0.9

regards heiko

six-heiko added a subscriber: six-heiko.
werner closed this task as Invalid.
werner removed a project: Bug Report.
werner added a subscriber: werner.

This is not a bug. See the chapter on how to specify a user ID. An 8 character
long string all consisting of valid hex characters is considered a key ID (in
your case 0x0564B63A). There are explicit ways to mark a user ID; for example:

  • Or by the usual substring:

"Heine"
"*Heine"

The '*' indicates substring search explicitly.