Wrong line endings when decrypting to console
Closed, ResolvedPublic

Description

When decrypting to console gnupg 2.1.3 creates "\r\r\n" line endings, while
decrypting to file creates "\r\n" line endings. Is this an expected behavior? Is
there any way to get the "\r\n" line endings when decrypting?

gpg --decrypt encrypted.gpg > DecryptConsole.txt
--> creates "\r\r\n" line endings

gpg --decrypt --output DecryptOutputfile.txt encrypted.gpg
--> creates "\r\n" line endings

Details

Version
2.1.3
gp_ast set Version to 2.1.3.May 8 2015, 3:02 PM
gp_ast added projects: gnupg, Bug Report.
gp_ast added a subscriber: gp_ast.
gp_ast added a comment.May 8 2015, 3:14 PM

Missed to explain that this does not happen when using gnupg 2.0.* and this occured
on Windows. I did not try this on *nix.

werner added a subscriber: werner.Aug 25 2015, 5:29 PM

The problem is likely due to a bug in libgpg-error. You may want to test the
latest master.

neal added a subscriber: neal.Nov 19 2015, 9:46 AM

gp_ast: have you gotten a chance to try this?

Hi Neal, I am not able to reproduce the issue with GnuPG 2.1.10 anymore.

Okay, Feel free to re-open if you see it again.

werner closed this task as Resolved.Dec 21 2015, 4:17 PM
werner claimed this task.
werner removed a project: Info Needed.