pinentry in text mode is skewed when using PuTTY and GNU screen
Closed, InvalidPublic

Description

This is with gnupg 2.1.2 from Debian experimental, on amd64. I wanted to use
pinentry in tty mode, because I didn't have an X display available. I was
using GNU screen and logged in with PuTTY 0.6.4 on Windows 7 64 bit.

While pinentry worked, the display was all skewed.

I've attached a screenshot.

Details

Version
0.9.0
bjmgeek set Version to 0.9.0.
neal added a subscriber: neal.Jun 1 2015, 5:03 PM

I just tried running pinentry-curses under screen on debian in an
xfce4-terminal. (You can run it directly from the command line by running
pinentry-curses and then typing 'getpin'.) I wasn't able to reproduce what I
saw in your screenshot. Also, I saw the proper symbolic characters to paint the
widget's borders (see screenshot).

I've make some changes to pinentry-curses recently. Perhaps you can try that
version (git). If you get the same results, does hitting control-L correctly
repaint the screen?

What program were you running? Perhaps it messed with the terminal settings.

I was using PuTTY 6.4 on Windows 7 64 bit.

On Mon, Jun 1, 2015 at 11:03 AM, Neal Walfield via BTS <
gnupg@bugs.g10code.com> wrote:

Neal Walfield <neal@walfield.org> added the comment:

I just tried running pinentry-curses under screen on debian in an
xfce4-terminal. (You can run it directly from the command line by running
pinentry-curses and then typing 'getpin'.) I wasn't able to reproduce
what I
saw in your screenshot. Also, I saw the proper symbolic characters to
paint the
widget's borders (see screenshot).

I've make some changes to pinentry-curses recently. Perhaps you can try
that
version (git). If you get the same results, does hitting control-L
correctly
repaint the screen?

What program were you running? Perhaps it messed with the terminal
settings.


nosy: +neal
status: unread -> chatting


GnuPG's BTS <gnupg@bugs.g10code.com>
<T1992>


neal added a comment.Jun 3 2015, 5:19 AM

Thanks for your quick reply. I meant: what program were you running on your
Debian box in screen? I doubt you directly called pinentry. Were you running
mutt? Were you running gpg?

Thanks.

Here is my .screenrc

#change the hardstatus settings to give
an window list at the bottom of the
#screen, with the time and date and with
the current window highlighted
hardstatus alwayslastline
hardstatus string '%{= bK}%-Lw%{=
KW}%50>%n%f* %t%{= bK}%+Lw%< %{= kG}%-=%D
%d %M %Y %c:%s%{+b y} %H %l'

deflogin on
shell /usr/bin/bash
vbell on

true | gpg2 --clearsign

On Tue, Jun 2, 2015, 11:19 PM Neal Walfield via BTS <gnupg@bugs.g10code.com>
wrote:

Neal Walfield <neal@walfield.org> added the comment:

Thanks for your quick reply. I meant: what program were you running on
your
Debian box in screen? I doubt you directly called pinentry. Were you
running
mutt? Were you running gpg?

Thanks.


GnuPG's BTS <gnupg@bugs.g10code.com>
<T1992>


neal added a comment.Jun 4 2015, 5:56 PM

I tried your screen configuration and I couldn't reproduce the problem.

Perhaps putty is configuring something differently. Can you reproduce the
problem when putty is not used (e.g., directly on the console or ssh'ing from a
GNU/Linux box)?

neal added a comment.Jun 4 2015, 6:08 PM

Also, see if you can reproduce the problem without screen. Thanks.

I will try this afternoon.

On Thu, Jun 4, 2015, 11:56 AM Neal Walfield via BTS <gnupg@bugs.g10code.com>
wrote:

Neal Walfield <neal@walfield.org> added the comment:

I tried your screen configuration and I couldn't reproduce the problem.

Perhaps putty is configuring something differently. Can you reproduce the
problem when putty is not used (e.g., directly on the console or ssh'ing
from a
GNU/Linux box)?


GnuPG's BTS <gnupg@bugs.g10code.com>
<T1992>


OK, I'll try that too.

On Thu, Jun 4, 2015, 12:08 PM Neal Walfield via BTS <gnupg@bugs.g10code.com>
wrote:

Neal Walfield <neal@walfield.org> added the comment:

Also, see if you can reproduce the problem without screen. Thanks.


GnuPG's BTS <gnupg@bugs.g10code.com>
<T1992>


neal added a comment.Jun 12 2015, 3:16 PM

bjmgeek: ping

I tried it in PuTTY without screen and it was not skewed. The line draw
characters looked funny (which I'm assuming is a Unicode thing), but they
were in a rectangle.

On Fri, Jun 12, 2015, 9:16 AM Neal Walfield via BTS <gnupg@bugs.g10code.com>
wrote:

Neal Walfield <neal@walfield.org> added the comment:

bjmgeek: ping


GnuPG's BTS <gnupg@bugs.g10code.com>
<T1992>


neal added a comment.Jun 12 2015, 4:26 PM

Hi Brian,

My best guess is that putty is advertising some terminal capabilities
that it does not (completely) support.

Thanks for your help,

Neal

At Fri, 12 Jun 2015 13:34:17 +0000,
Brian Minton wrote:

I tried it in PuTTY without screen and it was not skewed. The line
draw characters looked funny (which I'm assuming is a Unicode thing),
but they were in a rectangle.

On Fri, Jun 12, 2015, 9:16 AM Neal Walfield via BTS
<gnupg@bugs.g10code.com> wrote:

Neal Walfield <neal@walfield.org> added the comment:

bjmgeek: ping
marcus closed this task as Invalid.Jun 28 2017, 5:19 PM