segfault after importing key, corrupting trustdb
Closed, ResolvedPublic

Description

$ gpg --import facebook.asc
gpg: key 0x2F3898CEDEE958CF: public key "Facebook, Inc." imported
gpg: Total number processed: 1
gpg: imported: 1

gpg: signal Segmentation fault caught ... exiting
Segmentation fault: 11

After that, gpg will always throw "gpg: signal Segmentation fault caught ... exiting"
until I remove trustdb.gpg which will solve the issue (losing all trust information).

Using OS X El Capitan 10.11.5 (15F34) and gpg (GnuPG) 2.1.12 with the attached file.

Details

Version
2.1.12
cri set Version to 2.1.12.Jun 17 2016, 5:30 PM
cri added a project: Bug Report.
cri added a subscriber: cri.

werner added a subscriber: werner.

I am not sure about the cause for this bug. However it might be fixed either be
2.1.3 (released a few days ago) or libgpg-error 1.23.

Workaround: Use
ggp --export-ownertrust >ot.txt
rm trustdb.gpg
gpg --import-ownertrust <ot.txt

Could you verify that the problem has been solved (in 2.1.14)?

cri added a comment.Aug 18 2016, 6:21 PM

I used your workaround and haven't been running into problems since. Unfortunately, I
don't currently have the time at hand to give it a thorough test run. If I do, I will
keep you updated.

FWIW, we are running build tests now on macOS Sierra w/o problems.

werner closed this task as Resolved.
werner claimed this task.