"make check" cannot run before "make install" with gnupg 2.1.19
Closed, ResolvedPublic

Description

If "make check" is run before "make install" I get "error running
'/usr/local/Cellar/gnupg21/2.1.19/bin/gpg2': probably not installed"

This seems specifically to affect gpgconf.scm and tofu.scm.

The path /usr/local/Cellar/gnupg21/2.1.19/bin/gpg2 is indeed where gpg2 gets
installed after "make install", but that's not where it is if we run "make
check" before "make install", since it hasn't been installed in the prefix yet.

This did not occur with 2.1.18.

Here is a full log:
https://gist.github.com/ilovezfs/7edc9b70f6f54dd032ac72eb112c47df

(Also attached)

Details

Version
2.1.19
ilovezfs added a subscriber: ilovezfs.
werner set Version to 2.1.19.Mar 2 2017, 9:30 AM
werner added a subscriber: werner.

Please describe your platform.
I guess the log is the same as in T2980, thus I will merge them.

werner added a comment.Mar 2 2017, 9:30 AM

Duplicate of T2980

werner added a project: Duplicate.

macOS 10.10, 10.11, 10.12

They're nearly the same, but T2980 has the workaround for this issue in
place (running make install first), so that it's clear the ssh-import.scm
problem is an independent issue.

werner added a comment.Mar 2 2017, 9:53 AM

Thanks. Can you please run the test again with

make check BIN_PREFIX=/usr/local/Cellar/gnupg21/2.1.19

werner assigned this task to justus.Mar 13 2017, 10:12 AM
werner added a subscriber: justus.

Any other suggestions?

Hi, I have been assigned to this bug, and we'll get to the bottom of this.

The plan is to patch the tests to dump the location of tools it thinks it should
use. I'd like you to run the tests with that patch then.

Thanks for working with us on these issues. It is really appreciated.

You're welcome. By the way, you may be interested in this PR since you are
obviously a stakeholder in the matter:
https://github.com/Homebrew/homebrew-core/pull/11083

Please feel free to comment/suggest/etc. if you have any thoughts!

I just pushed c7833eca38fdb8d9ba7b59438ea87d651b8bf7ba that will help us
diagnose the problem. Would you be so kind to apply it and rebuild your package?

justus closed this task as Resolved.Mar 15 2017, 3:14 PM

Fixed in a98459d3f4ec3d196fb0adb0e90dadf40abc8c81.

Thanks for helping us diagnose this issue. Finally I understood the problem and
was able to reproduce it. Please keep filing bugs :)

Yup! Fix works. Thanks, Justus.

ilovezfs reopened this task as Open.Mar 15 2017, 3:30 PM
justus closed this task as Resolved.Mar 15 2017, 3:35 PM