GPGME's GpgmeppConfig.cmake uses .so not .dylib on macOS
Closed, ResolvedPublic

Description

This was reported to Homebrew in https://github.com/Homebrew/homebrew-core/issues/13925.

The shared library extension ".so" is hard coded in the file lang/cpp/src/GpgmeppConfig.cmake.in.in but on macOS the shared library extension is ".dylib"

As a workaround, I'm doing this in the Homebrew formula:

inreplace "lang/cpp/src/GpgmeppConfig.cmake.in.in", "libgpgme.so;",
                                                    "libgpgme.dylib;"

(https://github.com/Homebrew/homebrew-core/pull/13926)

It would be great if this could be fixed upstream, though. Thanks!

ilovezfs created this task.May 25 2017, 4:35 PM
justus assigned this task to aheinecke.Jun 1 2017, 10:44 AM
justus triaged this task as Normal priority.
justus added a project: gpgme.

Uhm I thought this was fixed with 2e661b9e1a9b50656a5c9646d7444a98477010c1 that should have been part of GPGME-1.9.0 are you sure that you are not seeing this with an older version?

According to the reporter in T2884 the patch worked.

@aheinecke Yes, the issue is with INTERFACE_LINK_LIBRARIES not IMPORTED_LOCATION.

*facepalm* Ooops. I see. Thanks for the report. I'll fix it.

@aheinecke thanks! My apologies for not making that clear in the initial report.

marcus closed this task as Resolved.Aug 10 2017, 3:14 PM