Outlook hangs when selecting and deleting many mails
Closed, ResolvedPublic

Description

Win 10 64bit
Outlook 2013:
With activated GpgOL Add-In Outlook hangs when selecting many e-mails.

Win 10 64bit
Outlook 2010:
Selecting works ok but deleting over 50 e-mails makes Outlook unresponsive and constantly changing the cursor from normal -> loading -> normal. It needs several minutes to delete them all. After deactivating GpgOL, Outlook deletes instantly.

It seems all selected mails getting loaded one by one?!

Installed software:
Gpg4win 3.0.0
GnuPG 2.2.1
GpgOL 2.0.1

Thanks

vRv8A created this task.Oct 4 2017, 12:54 PM
vRv8A created this object in space S1 Public.
aheinecke triaged this task as High priority.
aheinecke added a subscriber: aheinecke.

Indeed indeed. I can reproduce and see that GpgOL is very active when many mails are selected. This is a regression, it worked with an older MIME enabled version. I'll look at it.

aheinecke changed the task status from Open to Testing.Nov 24 2017, 2:55 PM

I'm pretty sure I've fixed it. It would be great if you could try with the latest beta (currently 2.0.4-beta6) from https://files.gpg4win.org/Beta/gpgol/ (just replace your gpgol.dll in the gpg4win/bin or bin_64 folder with the one from there. To confirm that it's fixed.

vRv8A added a comment.Nov 24 2017, 2:57 PM

Great, I'll do it :)

Thank you

vRv8A added a comment.Nov 28 2017, 7:25 AM

Tested GpgOL 2.0.4-beta6 with Outlook 2010 32bit and Outlook 2013 32bit on Win 10 1709 64bit.

Both of them now run flawlessly.

@aheinecke Thank you for your great work

aheinecke closed this task as Resolved.Nov 28 2017, 7:53 AM

Thank you, too for the report and testing.

Now we have to do a 3.0.2 release sooner rather then later because I think that this bug is pretty big :-/