Gpg4win 3.0.0: Outlook crashes when pasting E-Mail Adress from Outlook Adress book in new email when PGP-Signing is activated
Closed, DuplicatePublic

Description

Steps to reproduce:

  1. create new email
  2. activate "Absichern->signieren" (aktivate sign) in GPG4win-Pluging; I didn't activate "Absichern->verschlüsseln" (dont't activate encrypt);
  3. open any contact from outlook adress book;
  4. go into E-Mail Field and copy E-Mail Adress into clipboard (with control c)
  5. paste clipboard content into the "An" field of the new email

Result: Text will not be shown in "An" field. Outlook immedeatly crashes. Error Box (see attachment{F196392}) suggests to deactivate the gpgol plugin.

This behavier is 100% reproducible on my machine

Other tests:
a) between step 4 and 5: copy clipboard content in a text editor or any other app. From there copy content again and past it into the email. Works perfectly
b) modify step 2 and deactivate "Absichern=> signieren". Works perfectly

Details

Version
GPG4win 3.0.0 officially released 2017-09-20, Windows 10 home 64bit, Outlook 2010, 64 bit
tstreibl created this task.Oct 15 2017, 1:26 PM

Did you try to sign and encrypt with an X.509 or S/MIME key or with OpenPGP Key?

Can you activate logging (see compendium) and please also post your logs?

I have both types of certificates stored in kleopatra; S/MIME from StartCOM and OpenPGP created by Kleopatra.

In the system settings outlook is not configured to sign with S/MIME. I don't know where to configure GPGOL to make the right choice between the two signatures. I would expect GPGOL to pop up a message box when sending the email if certificate situation is unclear - at least not to crash.

Please keep in mind that I have this ribbon buck (see T3441), too.

Please find attached log files from keopatra and gpgol.

JochenSaalfeld closed this task as Invalid.

Then this is a duplicate of T3442 as well! Thank you for you Logfiles and your report!