GpgOL cannot verify greater than level 0 if addresses are capitalized
Closed, ResolvedPublic

Description

Hello,

every time I receive an encrypted or signed message. GpgOL shows that the used key does not claim the address like "Johnny.Leone@example.com".
I'm using GpgOL with an exchange mail server which "translates" the receiving address to a capitalization address like "Johnny.Leone@example.com". All these emails are also sent over the exchange server. When I'm receiving mails from external mail servers without capitalization in the addresses there is no such problem.

The used keys also has separate identities for these addresses.

Thanks.

Details

Version
2.0.6
aheinecke triaged this task as Normal priority.
aheinecke claimed this task.
aheinecke added a subscriber: aheinecke.

Mh, that is strange and indeed a bug if that is so. GpgOL should do some simple normalisation which should prevent exactly such a problem. I'll look into it.

I can't reproduce this. I sent myself a Mail with capitalized "Andre.Heinecke@intevation.de" while my key only has an identity for "andre.heinecke@intevation.de" and it worked as expected:

Maybe you are running in a different problem we just recently fixed a problem with exchange in the cause of T3802 where the wrong sender address would be taken.

Could you please try with the current beta ( https://www.gpg4win.org/version3.1.html ) to see if the problem still exists? And if so could you then please provide a debug log?

Thanks!

Thanks for the help,

I've tested the beta client and now it works for me and my coworker. Now all encrypted and signed messages gets there security level.

I think this issue can now closed. :)

Thanks.

aheinecke closed this task as Resolved.Mar 8 2018, 3:27 PM

Cool! Thanks for testing :-)