GPGOL: No body in the mail and gpgolXXX.dat file attached when opening with Thunderbird/Enigmail + Exchange and Exquilla
Closed, WontfixPublic

Description

Dear

I installed the latest version of gpg4win which is v3.1.0. Also the GPGOL v2.1.0 plugin was installed in my Outlook 2016 installation. The e-mail address used in both Outlook and Thunderbird is the same and is going over Exchange server. When I send e-mail to other users with an attachment who use the Outlook/GPGOL combination, it works perfectly. But when people who use Thunderbird in combination with Exquilla (Exchange) and Enigmail, try to open the mail, the only thing they see is an empty mail with an attachment named gpgolXXX.dat.

In GPGOL I have set the option "Send OpenPGP mails without attachments as PGP/Inline" and in Kleopatra I've set the following option as an extra next to the default ones: "create signed or encrypted files as text files."

Would you know what the problem could be? What can I do from my side to test this further?

Kind Regards
Digihash

Details

Version
2.1.0
digihash created this task.Apr 18 2018, 1:47 PM
aheinecke renamed this task from GPGOL: No body in the mail and gpgolXXX.dat file attached when opening with Thunderbird/Enigmail to GPGOL: No body in the mail and gpgolXXX.dat file attached when opening with Thunderbird/Enigmail + Exchange and Exquilla.Apr 19 2018, 7:24 AM
aheinecke triaged this task as Normal priority.Apr 19 2018, 7:28 AM
aheinecke claimed this task.
aheinecke added a subscriber: aheinecke.

Thanks for the report.
I clarified the title a bit to include exchange / exquila.

I strongly suspect that the problem is with exquilla. Exchange stores messages internally in MAPI which is a Microsoft format. In this storage we indeed have the gpgolXXX.dat which contains the MIME strucutre of a mail. In general this is converted to "MIME" when the message is exchanged (even with two Outlooks communicating over Exchange) This conversion does not appear to happen with Exquilla and then the MAPI data is synced.

I'll look into it but don't expect a quick fix. It is more likely that we need to fix this either in Exquilla or in Enigmail. I have contributed to Enigmail in the past so I could do this, too.

aheinecke closed this task as Wontfix.Apr 19 2018, 1:14 PM

Ok I tested with Exquilla. I configured an Exchange account once through Thunderbirds built-in account (IMAP) and once with Exquilla

The same Mail in the same Thunderbird synced by Thunderbird itself works. With Exquilla I only see attachments.
I tried to send an encrypted Mail through Exquilla but this was not supported.
I sent an Encrypted mail with attachment through the thundebrid account and could not look at it using Exquilla.
I also sent a PGP/MIME mail from KMail and it could not be opened through Exquilla.

I take it that Enigmail and Exquilla don't work well together and that using Exquilla does not support PGP/MIME.

As even a Mail sent from the same Enigmail can't be viewed properly I do not see this as a GpgOL Bug. IMO this bug is in Exquilla as Mails behave properly when using Thunderbirds builtin access.

Alright, I will create a ticket with Exquilla to see with them if this could be fixed on their side.

Thank you for all the testing.

Kind Regards
Digihash

OliverL added a subscriber: OliverL.Oct 7 2019, 2:54 PM

I have the same effect if I send a signed text-only or HTML email using Outlook 365 and our Exchange 365 and if I view the mail on Outlook on Android. The mail shows no contents only the file. If I view the mail using Outlook 365 on my PC or Windows 10 Mail it looks fine.
If I address it also to my Microsoft account and my Gmail account (using all adresses in the TO: field of the same mail) the email looks normal in the Gmail Android app and (!) in Outlook for Android.
So the same mail - both in the same Outlook for Android app - looks correct in my Microsoft account inbox but only shows the file in my Exchange inbox - in the same Outlook App. Weird… Nokia 7 plus, Android 9, newest patch level (September 2019) and no updates in Google Play Store.
BTW: In Exchange 365 I configured the message flow, default remote domain (there is no other) to never to use Rich Text, always and only HTML.

Kind regards
Oliver