I can not import my secret private key -> always failure
Closed, ResolvedPublic

Description

Hey there, i had to install GPGOL on some company laptops, since we need to encrypt or mails send to our external partner, the german police. While encrypting the mails works well and the import on nearly every computer was flawless, one single computer cant import our secret key. He cant even create an own new key, just nothing happens.

Popup shows: "Total number processed: 1 Imported: 1 Secret keys processed: 1 Secret keys NOT imported: 1"

We all use Windows 10 laptops with the newest updates. It worked totally fine on 7 computers, only this one is making trouble. I would appreciate any help.
All the best
Dorian

Details

Version
3.13
aheinecke triaged this task as Normal priority.Oct 17 2018, 9:17 AM
aheinecke claimed this task.
aheinecke added a subscriber: aheinecke.

Hi,

Your best bet is to try it on the command line to see if that provides some more useful output:

Open windows cmd.exe and in there execute "gpg --import c:\path\to\key"

Depending on the error a common advice is to move the GnuPG home directory (%APPDATA%\gnupg) to something like %APPDATA%\gnupg_broken .

And then try again with a fresh homedir.

If there is nothing secret in the homedir (no or empty private-keys-v1.d) and this was the cause, please attach a zip of the broken homedir here so that we can analyse the broken state and might prevent such problems in the future.

Thanks,
Andre

Hi Andre,
thanks for the feedback, will try this asap when i have the chance to get on the laptop of my co-worker. Will update you afterwards. Thanks for the help!
All the best
Dorian

der.dorian added a comment.EditedOct 17 2018, 10:38 AM

Hi Andre,

the common advice with the gnupg folder worked fine! Awesome! Thanks for your help and feedback. Have a great day!

All the best
Dorian

aheinecke closed this task as Resolved.Oct 24 2018, 3:23 PM