gpg-zip embeds the build-time path for tar instead of finding it at runtime.
Closed, ResolvedPublic

Description

see https://bugs.debian.org/913582 for an example of this problem.

The problem is with the use of AC_PATH_PROG in m4/tar-ustar.m4.

I think i can work around this in debian by passing --with-tar=tar to ./configure but that seems like a silly thing to have to pass explicitly.

dkg created this task.Wed, Nov 14, 7:23 AM
werner added a subscriber: werner.Wed, Nov 14, 1:11 PM

gpg-zip is deprecated because we have replaced it by gpgtar. Given that you have a workaround for Debian I tend to close this bug as WONTFIX.

The problem with gpg-zip is that it is designed as a replacement for pgp-zip, but on current Unix systems it is not quite compatible with PGPZIP in that it may create archives which can't be unpacked by PGPZIP. gpgtar implements the ustar specs and is thus fully compatible with the PGPZIP de-facto standard. The m4 test for ustar is only an approximation and does not guarantee that ustar format is created.

gpg-zip has not yet been removed from gnupg because I fear that people are using it with modern tar versions to archive longer filenames and extended attributes. It won't be in master and I guess I should let gpg-zip print a deprecation warning.

Let me also note that gpg-zip was not installed since 2006 due a conflict with gpg1.

dkg added a comment.Wed, Nov 14, 6:48 PM

i don't see any active use of it in all of debian: https://codesearch.debian.net/search?q=gpg-zip

(it only shows up in tab-completion and filesystem indexes).

will you add a deprecation warning to gpg-zip in STABLE-BRANCH-2-2 ?

I have a warning already in my working copy.

werner closed this task as Resolved.Thu, Nov 15, 4:16 PM
werner claimed this task.
dkg added a comment.Sun, Nov 18, 7:52 PM

hm, adding: --with-tar=tar to my invocation of ./configure appears to leave gpg-zip with:

TAR=

which clearly is going to be a problem :(