compile GnuPG v2.3.0 GPG_ERR_NO_SERVICE
Closed, InvalidPublic

Description

Hi all,

While trying to compile the v2.3.0 GIT commit id: 116dfb20013b73b950bbcee1d1f6c2a5d1d7ffdd

on
Operation System

Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

GnuPG v2.3.0-unknown has been configured as follows:

Revision:  0000000  (0)
Platform:  GNU/Linux (x86_64-pc-linux-gnu)

OpenPGP:   yes
S/MIME:    yes
Agent:     yes
Smartcard: yes (without internal CCID driver)
G13:       no
Dirmngr:   yes
Gpgtar:    yes
WKS tools: yes

Protect tool:      (default)
LDAP wrapper:      (default)
Default agent:     (default)
Default pinentry:  (default)
Default scdaemon:  (default)
Default keyboxd:   (default)
Default dirmngr:   (default)

Dirmngr auto start:  yes
Readline support:    no
LDAP support:        no
TLS support:         no
TOFU support:        no
Tor support:         yes
 -o apdu.o apdu.c
apdu.c: In function ‘apdu_dev_list_start’:
apdu.c:1967:31: error: ‘GPG_ERR_NO_SERVICE’ undeclared (first use in this function); did you mean ‘GPG_ERR_NO_ENGINE’?
             return gpg_error (GPG_ERR_NO_SERVICE);
                               ^~~~~~~~~~~~~~~~~~
                               GPG_ERR_NO_ENGINE
apdu.c:1967:31: note: each undeclared identifier is reported only once for each function it appears in
Makefile:575: recipe for target 'apdu.o' failed
make[2]: *** [apdu.o] Error 1

Any ideas?
Thanks

Details

Version
v2.3.0
pow created this task.Nov 22 2019, 12:44 PM
werner closed this task as Invalid.Nov 22 2019, 3:23 PM
werner added a subscriber: werner.

Please no bug reports for the development branch. You need to have a recent libgpg-error. We do not update the requirements checked by configure for master immediately. It is better to report this to gnupg-devel if you are sure that you have the latest versions of all libraries.