WinPT 0.9.92 crashes upon start
Closed, ResolvedPublic

Description

Release: WinPT 0.9.92 (ZIP archive, no installer)

Environment

Windows XP Professional (x86 32-bit), GnuPG 1.4.0 (Cygwin package)

Description

When WinPT is started, an error message box appears: "Error: Clipboard Decrypt/Verify (ALT+CTRL+D)". After clicking "OK", another one appears: "WinPT Error: Could not read GnuPG version." After clicking "OK" there again, a dialog box appears: "Delete Clipboard Contents: Do you want to delete the contents from the clipboard?" Then regardless of clicking "Yes" or "No", WinPT silently disapears (process terminates).

I suspect there is a problem with my Cygwin versino of GnuPG. On the other hand, gpg itself is fine and can be executed manually without any problem. Its path is stored in the registry (HKCU\Software\GNU\GnuPG) as well as the GnuPG home dir.

How To Repeat

  1. Install Cygwin and the GnuPG package.
  2. Download and unpack WinPT binary archive.
  3. Run WinPT

    Reproducability: Always

Fix

Unknown

werner added a subscriber: werner.Jul 28 2006, 9:36 PM

Timo, please check whether this is still the case. IF it is a problem we might
want to just document thsi as a problem.

twoaday lowered the priority of this task from Unbreak Now! to Normal.Jul 29 2006, 11:06 AM

I could not reproduce the problem any longer with 1.0.0preX

And the error at the start is propably because another application
already reserved the hotkeyn ALT+CTRL+D. Currently there is no easy way
to find out which application this is.

werner closed this task as Resolved.Jul 29 2006, 11:52 AM