gpgOL Outlook PlugIn error code: 1
Closed, InvalidPublic

Description

Since update to MS Office 365 Pro Plus (Version 1908) the gpgOL PlugIn doesn´t work any more.
If I receive an encrypted email I get following error message: "OpenPGP Encrypted message (decryption not possible)" "Could not decrypt the data: Unsupported protocol"

If I want to send an email encrypted I get following error message:
"Operation failed.
This is usually caused by a bug in GpgOL or an error in your setup. Please see https://www.gpgp4win.org/reporting-bugs.html or ask your Administrator for support. Code: 1"

I already re-installed gpgOL without any success.

Details

Version
3.1.11
aheinecke closed this task as Invalid.Jan 30 2020, 12:53 PM
aheinecke added a subscriber: aheinecke.

That means that the GnuPG Backend does not work. I do not think that the office update is the reason, me and others use GpgOL with the most recent versions of Office Pro Plus without issue.
Have you possibly modified you gnupg config files? If there is a bad value in there it would result in such an error.

You can try moving away all *.conf files in %APPDATA%\gnupg

On the Command line or in Kleopatra if you try to encrypt / decrypt using Kleopatra you might also get a better error.

As this is a support question and does not appear for now to be a "bug" I'll close this issue, we can always reopen it if it turns out to be a Bug.

I have opened T4829 as a result of this issue because I strongly suspect it's a broken configuration.