GPGME_CREATE_NOEXPIRE seems not to be available since 1.8.0
Closed, ResolvedPublic

Description

The documentation states that GPGME_CREATE_NOEXPIRE is available since release 1.8.0 (Wed Nov 16 13:29:02 2016) but it seems that the commit that introduced GPGME_CREATE_NOEXPIRE (de708e5934cda380dbc3ae51f587c09041de7562) was written on Wed Feb 15 16:17:13 2017. Thus I think that GPGME_CREATE_NOEXPIRE is available since 1.9.0 that was released on Tue Mar 28 16:21:37 2017.

See Patch

.

dup created this task.Apr 21 2020, 6:13 PM
dup added a project: gpgme.Apr 21 2020, 6:26 PM
dup claimed this task.Apr 21 2020, 6:29 PM
dup updated the task description. (Show Details)Apr 21 2020, 7:53 PM
dup updated the task description. (Show Details)
dup edited projects, added Not A Bug, patch; removed Bug Report.Apr 25 2020, 10:39 PM
dup removed a subscriber: dup.
aheinecke closed this task as Resolved.May 8 2020, 12:35 PM
aheinecke added a subscriber: aheinecke.

Thanks for the patch, applied!
You are correct the NEWS file states that this was added in 1.9.0