Revocation Date after importing a Rev-Cert
Closed, ResolvedPublic

Description

On 2020-06-17 i imported a revocation cert to my keyring. The key is revoked BUT the timestamp shows the date the Revocation-Cert was created instead of the date it was imported/applied!

In consideraton that gpg auto-generates a Revocation-Certificate right after Keypair-Generation and you apply that Revocation-Certificate eg. 10 years later, it still suggests that the key was revoked right after the Key-Pair was generated.

If possible gpg should display the date the Revocation-Cert was applied instead of the date it was created.

Details

Version
2.2.20
ElBarto created this task.Jun 17 2020, 4:58 PM
ElBarto updated the task description. (Show Details)Jun 17 2020, 5:22 PM
werner added a subscriber: werner.Jun 18 2020, 10:32 AM

That is unfortunately not possible because there is no fixed link between the key and the rev cert. Instead they are linked via cryptographic signatures. The pre-generated rev certs are a fail stop measure in the case that the user lost access to the private key and can't create a revocation with a concrete reasons etc.

werner edited projects, added Not A Bug, gnupg; removed Bug Report.Jun 18 2020, 10:33 AM
werner closed this task as Resolved.
werner claimed this task.