can not find the runtime library libgcc_s_sjlj-1.dll
Closed, InvalidPublic

Description

Cannot cross-compile on Arch Linux. I have installed all necessary packages, but get:

❯ ./autogen.sh --build-w32          
Using /home/ave/w32root as standard install directory
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/home/ave/.local/soft/gpg4win/missing: Unknown `--is-lightweight' option
Try `/home/ave/.local/soft/gpg4win/missing --help' for more information
configure: WARNING: 'missing' script is too old or missing
checking for i686-w64-mingw32-strip... i686-w64-mingw32-strip
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether UID '1000' is supported by ustar format... yes
checking whether GID '1000' is supported by ustar format... yes
checking how to create a ustar tar archive... gnutar
checking whether to enable maintainer-specific portions of Makefiles... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... i686-w64-mingw32
checking whether NLS is requested... yes
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for i686-w64-mingw32-gcc... i686-w64-mingw32-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.exe
checking for suffix of executables... .exe
checking whether we are cross compiling... yes
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i686-w64-mingw32-gcc accepts -g... yes
checking for i686-w64-mingw32-gcc option to accept ISO C89... none needed
checking whether i686-w64-mingw32-gcc understands -c and -o together... yes
checking whether make supports the include directive... yes (GNU style)
checking dependency style of i686-w64-mingw32-gcc... gcc3
checking how to run the C preprocessor... i686-w64-mingw32-gcc -E
checking for i686-w64-mingw32-ranlib... i686-w64-mingw32-ranlib
checking for i686-w64-mingw32-ar... i686-w64-mingw32-ar
checking for i686-w64-mingw32-strip... (cached) i686-w64-mingw32-strip
checking for i686-w64-mingw32-dlltool... i686-w64-mingw32-dlltool
checking for make... make
checking for unzip... unzip
checking for tar... tar
checking for mkdir... mkdir
checking for cp... cp
checking for rm... rm
checking for stow... stow
checking for makensis... makensis
checking for zcat... zcat
checking for texi2dvi... texi2dvi
checking for dvipdf... dvipdf
checking for convert... convert
checking for sha1sum... sha1sum
checking for msgfmt... /usr/bin/msgfmt
checking for gitlog-to-changelog... no
checking for gcc... gcc
checking for i686-w64-mingw32-x86_64-w64-mingw32-strip... no
checking for x86_64-w64-mingw32-strip... x86_64-w64-mingw32-strip
configure: WARNING: using cross tools not prefixed with host triplet
configure: Using autodetected 12 make jobs. You can override this by setting GPG4WIN_PARALLEL.
configure: error: can not find the runtime library libgcc_s_sjlj-1.dll in the default locations.
                     Use the --with-libgcc_s_sjlj-1 option to set the path directly.

Internet says this is a problem with dynamic linking [0]. Any advice?

[0] https://stackoverflow.com/questions/12921911/mingw-libgcc-s-sjlj-1-dll-is-missing

Details

Version
gpg4win-3.1.12-23-gfa3dff39
avemilia created this task.Wed, Sep 2, 11:03 PM
werner closed this task as Invalid.Thu, Sep 3, 8:37 AM
werner added a subscriber: werner.

You need to get you toolchain correctly installed.

This is not a bug, for help please use the gnupg-devel ML.