About Kleopatra showing unknown version number
Closed, ResolvedPublic

Description

Kleopatra comming with Gpg4win 3.1.13 showns "Version Unknown Windows Version" in the about dialog.

bernhard created this task.Sep 7 2020, 10:24 AM
bernhard triaged this task as Low priority.Sep 7 2020, 10:27 AM
aheinecke raised the priority of this task from Low to Normal.Sep 8 2020, 8:42 AM

Argh, that will also be shown when Kleopatra first starts and no keys are visible. This is caused by a change in Gpg4win to check the integrity of the Version by verifying that the VERSION file is signed.

I've only partially implemented that and forgotten about it before the 3.1.13 release which was not fully planned.

Actually this might be a reason to do a 3.1.14 soon as the next release was planned to have a long beta stage with 4.0

aheinecke changed the task status from Open to Testing.Sep 9 2020, 4:32 PM

This is fixed now, but of course it will only affect the next release :-/

s7r added a subscriber: s7r.Sun, Nov 29, 7:42 PM
This comment was removed by s7r.
s7r closed this task as Resolved.Sun, Nov 29, 7:49 PM

I confirm I have tried with latest 3.1.14 on two different computers (Windows) where I had this "Unknown version" bug going on and they both properly show 3.1.14 version as it should.

@s7r Thanks for testing and letting us know!