gnupg-2.2.20 build error
Closed, ResolvedPublic

Description

CentOS Linux release 7.8.2003 (Core)

System - Linux k2003734 3.10.0-1127.10.1.el7.x86_64 #1 SMP Wed Jun 3 14:28:03 UTC 2020 x86_64
x86_64 x86_64 GNU/Linux

Compiler - gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-39)
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

./configure --prefix=/usr/local/gnupg-2.2.20 --with-libgpg-error-prefix=/usr/local/libgpg-error-1.38 --with-libgcrypt-prefix=/usr/local/libgcrypt-1.8.5  --with-libassuan-prefix=/usr/local/libassuan-2.5.3 --with-ksba-prefix=/usr/local/libksba-1.4.0 --with-npth-prefix=/usr/local/npth-1.6

resulted in:

GnuPG v2.2.20 has been configured as follows:

        Revision:  5094bb08e  (20628)
        Platform:  GNU/Linux (x86_64-pc-linux-gnu)

        OpenPGP:   yes
        S/MIME:    yes
        Agent:     yes
        Smartcard: yes 
        G13:       no
        Dirmngr:   yes
        Gpgtar:    yes
        WKS tools: yes

        Protect tool:      (default)
        LDAP wrapper:      (default)
        Default agent:     (default)
        Default pinentry:  (default)
        Default scdaemon:  (default)
        Default dirmngr:   (default)

        Dirmngr auto start:  yes
        Readline support:    yes
        LDAP support:        yes
        TLS support:         gnutls
        TOFU support:        yes
        Tor support:         yes

Error in "make":

.deps/t_ldap_parse_uri-http-common.Tpo -c -o t_ldap_parse_uri-http-common.o `test -f 'http-common.c' || echo './'`http-common.c
In file included from http-common.c:26:0:
dirmngr.h:32:18: fatal error: ksba.h: No such file or directory
 #include <ksba.h>
                  ^
compilation terminated.

By explicitly pointing out the location of ksba.h in dirmgr.h the build process completed.

Details

Version
2.2.20
gostal created this task.Thu, Oct 1, 5:35 PM
werner closed this task as Resolved.Thu, Oct 1, 5:53 PM
werner edited projects, added Not A Bug; removed Bug Report.
werner claimed this task.
werner added a subscriber: werner.

You used custom options which did not pick up the proper libksba. Install libksba correctly then try again. Please direct further questions to the mailing list and please build the latest version 2.2.23 and not an arbitrary old version.