Plug-in cannot get data from the current window
Closed, ResolvedPublic

Description

Release: 0.9.10

Environment

Windows XP Professional w/ SP2
MS Office 2003 w/ SP2 (Including Outlook 2003 w/ SP2)
Gpg4win 1.0.1

Description

The Outlook plug-in does not appear to work properly. It does not present any buttons for encrypting or decrypting messages in the message window.

While I have been able to use the tool form the system tray to generate an encrypted message, it will only perform this function once. On the second (or subsequent) attempts, I receive an error message that reads "Make sure the window contains text. Could not extract data from the current window."

I have confirmed that the cursor is in the source window prior to involing the gpg tool from the system tray.

Fix

Unknown

registration added a subscriber: registration.

Actually the current window function is not related to the
plugin. IF the buttons are not visible in the Outlook "New Mail" window,
it is likely that an editor, maybe Word, is used.
In this case you won't see the GPGol buttons.

The only fix is NOT to use an editor but directly Outlook.

werner added a subscriber: werner.Dec 10 2008, 3:54 PM

Due to time constraints, the 0.9 series of GpgOL is no longer supported.
I am sorry for this inconvenience. Gpg4win/2 will soon be released featuring a
heavily rewritten GpgOL.

werner closed this task as Resolved.