Page MenuHome GnuPG

DEPRECATION: gpg 1.14.0-unknown has a non-standard version number
Closed, InvalidPublic


Linux system, raspberrypi, Linux 6.1.21-v7+ armv7l, bullseye,

pi@pihole:[~] $ pip show gpg
Name: gpg
Version: 1.14.0-unknown
Summary: Python bindings to the GPGME API of the GnuPG cryptography library.
Author: The GnuPG hackers
License: LGPL2.1+ (the library), GPL2+ (tests and examples)
Location: /usr/lib/python3/dist-packages

The upgrade of the pypi package pi gives error and will stop working with version 24.0:

pi@pihole:[~] $ pip3 install --upgrade pip
Defaulting to user installation because normal site-packages is not writeable
Looking in indexes:,
Requirement already satisfied: pip in ./.local/lib/python3.9/site-packages (23.2.1)
Collecting pip

Downloading (2.1 MB)
   ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 2.1/2.1 MB 2.9 MB/s eta 0:00:00

DEPRECATION: gpg 1.14.0-unknown has a non-standard version number. pip 23.3 will enforce this behaviour change. A possible replacement is to upgrade to a newer version of gpg or contact the author to suggest that they release a version with a conforming version number. Discussion can be found at
Installing collected packages: pip

Attempting uninstall: pip
  Found existing installation: pip 23.2.1
  Uninstalling pip-23.2.1:
    Successfully uninstalled pip-23.2.1

Successfully installed pip-23.3

Event Timeline

werner added a subscriber: werner.

Sorry, we have nothing do to with this pypi thing even if that file claims " The GnuPG hackers".