type pswd| gpg --passphrase-fd 0 --output file --decrypt file does not work w/ Win 2003 Server
Closed, ResolvedPublic

Description

Release: v1.4.4

Environment

Windows 2003 Server

Description

When following the documentation to pipe the passphrase to the decrypt command,
type passphrase | gpg --passphrase-fd 0 OPTIONS COMMAND
will always get the usage error.
gpg [options] [command]

How To Repeat

Install v1.4.4 (or v1.4.1, v1.4.2) on a Windows 2003 Server. Create a key pair. Export the public key. Encrypt a file with the public key. Try the decrypt command piping the passphrase.

Fix

Unknown

werner added a subscriber: werner.Jul 31 2006, 12:50 PM

Timo can you reproduce it?

werner added a subscriber: gnupg-hackers.
werner added a subscriber: twoaday.

I'm not sure if I understand the problem. If you try to pipe the passphrase
to the gpg process, you should use --decrypt or even no command, but never
--decrypt-file _and_ --output because --decrypt-file is supposed to work with
more than one file and thus you cannot force a single output file.

werner added a comment.Oct 2 2006, 8:01 PM

My guess is that the reporter took the docs too literal:
type passphrase | gpg --passphrase-fd 0 OPTIONS COMMAND
and entered "OPTIONS COMMAND". Thus closing.

werner closed this task as Resolved.