Outlook crashes when recipient's email address is not associated with the public key, that the message is being encrytped to
Closed, ResolvedPublic

Description

Environment

Windows XP SP2
Outlook 2003 (11.8010.8036) SP2

  • Use Microsoft Office Word 2003 to edit email messages is OFF

All available (as of time of writing) MS Office 2003 updates have been applied
Gpg4win 1.0.6
GPGol 0.9.90

Description

I'm trying to send an encrypted email message to a contact that is not
associated with the public key that I'm encrypting to. The 'Recipient dialog'
window pops up - showing the email address of the recipient under 'Recipients
which were NOT found'. I then pick one of the keys from my key-ring and submit -
Outlook crashes. Sometimes it displays Microsoft's 'Bug report' dialog and
sometimes it doesn't.
After I start Outlook again, I can find the failed messages saved in the Outbox.

I haven't tested this, because I didn't want to tweak my key-pair, but someone
else has done it and according to them, Outlook crashes even if the UserID is
added to the key as a second ID:
http://wald.intevation.org/forum/message.php?msg_id=608

I can verify, that whenever I try to send encrypted email to a recipient, who's
email address is associated with the single UserID of the public key, I'm
encrypting to, it is being sent encrypted just fine.

Steps to reproduce

  1. Create a new email message - HTML, Unicode (UTF-8);
  2. Choose a recipient who's email address is not associated with the UserID of

the public key, that you will be encrypting to;

  1. Press the 'Encrypt' button on the GPGol toolbar;
  2. Press 'Send';
  3. In the 'Recipient dialog' box that would pop up, choose one of the public

keys from your key-ring - none of the UIDs, associated to this key should match
the recipient's email address - then submit the dialog.

Expected result

The email message should be encrypted and sent, regardless of whether
recipient's email address matches any of the UserID's associated with the public
key that the message is being encrypted to. This is the reason the 'Recipient
dialog' is there - to pick whatever public kye you want. Otherwise the keys
should be set automatically, based on recipient's email address.

observer added a subscriber: observer.
werner added a subscriber: werner.Sep 19 2006, 9:45 PM

IRIC, Timo already fixed this problem. We need to do a new release, though.

werner assigned this task to twoaday.Sep 19 2006, 9:45 PM
werner added a subscriber: twoaday.

Release done (1.0.7).

Well, the release is 0.9.91. It is inlcuded in gpg4win 1.0.7.

twoaday closed this task as Resolved.Oct 29 2006, 12:24 PM
twoaday removed a project: Testing.