Kleopatra: Handle disabled keyserver when updating a certificate
Closed, ResolvedPublic

Assigned To
Authored By
• ikloecker
Mar 11 2024, 11:41 AM
Tags

Description

How to reproduce:

  • Set OpenPGP keyserver to none in Kleopatra's config dialog.
  • Open the details of an OpenPGP certificate and click Update.

Expected result: No keyserver lookup is performed.

Actual result: No change is reported for the keyserver lookup.

That "no change" instead of an error is reported is caused by T7036: gpgme: gpgme_op_receive_keys does not return an error if keyserver lookup is disabled, but Kleopatra should just skip the keyserver lookup if the keyserver is set to none.

Event Timeline

• ikloecker created this task.
• ikloecker moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.
• ikloecker changed the task status from Open to Testing.Mar 11 2024, 3:38 PM

Instead of "The key hasn't changed." Kleopatra now displays "The update was skipped because no keyserver is configured."

what about the case that the key has a mail address? Is WKD still checked?

Sure WKD is still checked if the conditions for an update via WKD are fulfilled.

• ebo moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.Oct 1 2024, 3:55 PM

Tested with gpg4win-Beta-75++:

When keyserver is "none" you get now the message: "Update skipped because no OpenPGP keyserver is configured."
Edit:
But WKD is not checked, either in that case.
This was because the expired test certificate was imported from a file. To check for certificates with another origin than WKD in WKD you have to set the option "Query certificate directories of providers for all user IDs"

• ebo moved this task from Restricted Project Column to Restricted Project Column on the Restricted Project board.
• ebo edited projects, added vsd33 (vsd-3.3.0); removed vsd33.