[gpgol] Bad signature when Outlook 2003 wraps line in plain text mode
Closed, ResolvedPublic

Description

I'm currently using Microsoft(r) Office Outlook(r) 2003 (11.8010.8036) SP2,
Windows Privacy Tray v1.0.0 (Aug 28 2006) and gpgol.dll v0.9.90.159.
Step to reproduce the issue:

  • In Outlook 2003, select menu Tools->Options->Tab "Mail Format"
  • Select "Plain Text" mode
  • Click "Internet Format" button
  • Leave 72 characters in the Wrap Line options
  • Write a new message and sign it
  • When the recipient receives the mail, the message will be wrapped, and if you

verify the signatures gpg says "Bad signature"

I think it's because the line wrapping is done AFTER the creation of the sign,
so the sign will be invalid.
To temporary resolve this, you can disable Line Wrapping by following the
Microsoft KB http://support.microsoft.com/kb/823921/en-us, but i think it's a
gpgol issue and not an outlook issue.

Best regards, and thank you for your work
Marco

aNt1X added a subscriber: aNt1X.

This is indeed a problem and we will consider to
offer pre-word wrap if the text contains very long
lines.

werner closed this task as Resolved.
werner claimed this task.

Due to time constraints, the 0.9 series of GpgOL is no longer supported.
I am sorry for this inconvenience. Gpg4win/2 will soon be released featuring a
heavily rewritten GpgOL.