/dev/random not found error during encryption with gpg1.4.3
Closed, ResolvedPublic

Description

In our recent project, we made use of gpg1.4.3 for encryption/decryption purposes.

In dev/test environment, everything worked fine. Installation of gpg on
production host is also successful. Dev/Test/ is "5.8 Generic_108528-24 sun4u
sparc SUNW,Ultra-4" & Prod is "5.8 Generic_117350-38 sun4u sparc
SUNW,Sun-Fire-480R".

When we tried to encrypt a file in production, it gave an error /dev/random not
found. Indeed the file is not there in production environment and because of
which we had a rollback for the release.

But I would like to know the list of all such mandatory runtime dependancies
that gpg requires. Is there any literature on web that details this? If so,
could you please provide the link? Are there any other patches/libraries that
need to installed on production for successful operation? Any help in this
regard is very highly appreciated.

Reddi added a subscriber: Reddi.
werner added a subscriber: werner.Dec 5 2006, 10:29 AM

The runtime dependecies depend are computed at build time. Thus building on one
system and running on another might lead to problems. Systems with and without
/dev/random are different.

Try
./configure --enable-static-rnd=unix

(This is not a bug report, so please ask on gnupg-users or check out tyhe
service directory at gnupg.org).

werner closed this task as Resolved.
werner claimed this task.