app-crypt/pinentry-0.7.2 - gtk2 fails with "** ERROR **: could not grab keyboard"
Closed, ResolvedPublic

Description

Werner,

So we can keep track of this.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=401957
http://bugs.gentoo.org/show_bug.cgi?id=165493

Seems to be a race condition, so at a specific point keyboard grab does not
work.

Details

alonbl set External Link to http://bugs.gentoo.org/show_bug.cgi?id=165493.
alonbl added a subscriber: alonbl.
alonbl added a comment.Jul 6 2007, 7:34 PM

Please release a new version of pinentry so that no external patches will be
required. Please also consult the patches at msg#2137.
Thanks!

alonbl added a comment.Jul 6 2007, 8:48 PM

Oh... so pinentry-0.7.3 was released without these.

werner added a subscriber: werner.Jul 9 2007, 9:46 AM

Applied fixed to SVN (-r 167).

(Note that *.info files should not be patched as they are build from .texi files)

werner closed this task as Resolved.Jul 9 2007, 9:46 AM
werner claimed this task.

The revert does not always work.

The expose event does not work too well either.
http://bugs.gentoo.org/show_bug.cgi?id=201951

So I reverted to using focus-in/out-event

map-event is too early for grab, and cannot be used.

0.7.4 works again very reliable for me - your previous change made it fail
almost always when it was first popped up. There must have been a reason that
whe don't used focus-in out when grabbing is enabled.

The question at hand is why it fails on gentoo whereas it works reliable on
Debian (Xorg 7.1 as well as all older versions).

Hello,

It works for me too... There are some users, however, that have this issue.

The problem is timing related, if I understand correctly the grab can work only
on shown windows... So on slow or loaded computers (I guess), the grab is
called too early, and fails.

You cannot call grab at the map event.

But I am not gtk programmer...

werner closed this task as Resolved.Dec 5 2008, 6:34 PM
werner added a project: Too Old.