t-gettime fail
Closed, ResolvedPublic

Details

External Link
http://bugs.gentoo.org/show_bug.cgi?id=184484
Version
2.0.5-2.0.7
alonbl set External Link to http://bugs.gentoo.org/show_bug.cgi?id=184484.Jul 7 2007, 6:40 PM
alonbl set Version to 2.0.5.
alonbl added projects: gnupg, Bug Report, Gentoo.
alonbl added a subscriber: alonbl.Jul 7 2007, 9:22 PM

There is also TAI timezone issue.

Still not fixed.

alonbl changed Version from 2.0.5 to 2.0.6.Aug 17 2007, 6:49 AM

glib-2.5
TZ="right/UTC" make check

Please echo of you use this bug database, as you ignore this issue for the last
two versions.

alonbl changed Version from 2.0.6 to 2.0.5-2.0.7.Sep 13 2007, 2:35 AM
werner added a subscriber: werner.Nov 15 2007, 4:25 PM

We discussed this on gnupg-devel@ around July 11. My conclusion was that

t-gettime.c tests the back and forth conversion between gmtime(3) and
timegm(3).  From my understanding the locale won't matter.  The input is
a time_t which is a specific way to describe the number of seconds since  
Epoch.  That number should be returned by timegm.

The problem seems to be that you are using the timegm emulation in
jnlib/mischelp.c which uses mktime and a TZ=UTC.  To me this seems to be
correct interpretation of POSIX.  Only localtime(3) should take TAI or
any other conversion into acount.

Well, you wrote that you are using the native timegm from glibc 2.5. Good, thus
it is not a problem with the emulation code but buried in glibc. Please take
the discussion abck to the ML and show me that this TAI is supported by POSIX.
It would also make sense to include the glibc hackers. Trying to discuss this
in a bug tracker does not make any sense.

I don't understand... You succeeded in reproducing this and have an issue with
glibc?
If you do, have you opened some kind of bug report/thread to solve this?

werner added a comment.Jul 9 2009, 4:40 PM

not a bug or - if at all - a bug in glibc. Further discussion please on the ML

werner closed this task as Resolved.Jul 9 2009, 4:40 PM
werner claimed this task.
werner added a project: Not A Bug.
werner removed a project: Stalled.