gpgol crashes in outlook 2007 and Vista
Closed, ResolvedPublic

Description

using the current version of gnupg, gpgol consistently crashes when running
Vista x86+ Outlook 2007

Unhandled exception at 0x65c99ddd in OUTLOOK.EXE: 0xC0000005: Access violation
reading location 0x00000000.

In the stack, it crashes at this instruction:
65C99DDD push dword ptr [eax]
The value of the data being pushed is 1707711965

Bug has been confirmed by Werner Koch

Details

Version
0.9.91
wng_z3r0 set Version to 0.9.91.
wng_z3r0 added a subscriber: wng_z3r0.
werner added a subscriber: werner.Sep 10 2007, 5:54 PM

The current - non fully working - code of GpgOL works fine under Vista and
OL2007. This is code more or less a rewrite of the old code; thus I am not sure
whether it makes sense to try making the old code working vor Vista.

However, if someone figures out the cause of the proble, I will add a patch and
do a new released based on the old code.

werner closed this task as Resolved.Dec 10 2008, 3:51 PM
werner claimed this task.
werner added a project: Too Old.

Due to time constraints, the 0.9 series of GpgOL is no longer supported.
I am sorry for this inconvenience. Gpg4win/2 will soon be released featuring a
heavily rewritten GpgOL.