GpgOL: emails in sent-folder can not be verified
Closed, ResolvedPublic

Description

I've created successfully a PGP/MIME signed E-Mail
(verifies well for the KMail recipient).

However, the copy in the Outlook sent folder can not be verified.
If I select "Verify signature" from the menu, nothing happens.

I am not sure whether this is a problem in GpgOL, Kleopatra
or specifically in my environment.

So, ideally I'd like to know whether other people can
reproduce this.

Details

Version
0.10.4-svn212
Jan-Oliver_Wagner set Version to 0.10.3 (Gpg4win 1.9.0-svn651).Dec 21 2007, 11:15 AM
Jan-Oliver_Wagner raised the priority of this task from Normal to High.Jan 10 2008, 9:59 AM
Jan-Oliver_Wagner changed Version from 0.10.3 (Gpg4win 1.9.0-svn651) to 0.10.4-svn205.
Jan-Oliver_Wagner assigned this task to werner.
Jan-Oliver_Wagner added a subscriber: werner.

This is still the case for 0.10.4-svn205.

I am raising priority to urgent and assigning to werner.

I have no idea on how to fix that.

I recall that we talked off-list about this and agreed that the UI-server part
should first be finished before we can work on thisagain. The UI server does
not yet fully work; in particular signature verification yelds wrong results.

I wonder why the email sent out to recipient is correct
and the copy in the sent-folder is defect.
To me this looks like the error can not be in UI Server Kleopatra
then ... ?

We are talking about Outlook and not about a regular MUA.
Anyway, the current SVN has code some sent messages.

I've tried 0.10.4-svn212 and still can oberve problems.

What happens now look a bit different:
I do get this text:
[Aufgrund eines Verarbeitungsfehlers in GpgOL ist der Inhalt dieser Nachricht
nicht sichtbar.]

If I explicitely select menu item "Unterschrift prüfen", nothing happens.

Let me know if I should try to create any sort of log file.

On Sat, 19 Jan 2008 00:23, gnupg@bugs.g10code.com said:

I've tried 0.10.4-svn212 and still can oberve problems.

Note that the fix works only for messages sent using the new version.

Shalom-Salam,

Werner

Yes, I did create a new signed PGP/MIME email.

It arrives well at the receipient (KDE Kontact).

Jan-Oliver_Wagner changed Version from 0.10.4-svn205 to 0.10.4-svn212.Jan 23 2008, 5:17 PM

I can confirm that with current release (svn220) it works.
Thus resolving.

Jan-Oliver_Wagner closed this task as Resolved.Feb 14 2008, 12:49 PM