update from 2.0.7 breaks existing gpgme applications
Closed, ResolvedPublic

Description

After update from 2.0.7 to 2.0.8, an existing gpgme application continues to
work with OpenPGP, but discontinues to work with CMS. Creating an S/MIME
signature with
"gpgerr=gpgme_op_sign(gpgctx,inputdata,outputdata,GPGME_SIG_MODE_NORMAL)" fails
with gpgme_strsource(gpgerr) being "KSBA" and gpgme_strerror(gpgerr) being "Not
found". I'm testing with my personal X.509 (resp. OpenPGP) certificates issued
by the DFN "Global" PKI.

The problem might possibly be related to T878.

On Jan 04, 2008; 05:24pm, M. Brinkmann wrote in the gpg-dev mailing list in the
thread "[Announce] GPGME 1.1.6 released" (regarding T878):

> > Which version of gpgsm do you use? The tests run fine here.
> $ gpgsm --version
> gpgsm (GnuPG) 2.0.8
Ok, I used 2.0.4 for testing the release. It is possible that
something changed which broke the test case, I'll have to check it
out. Thanks for letting me know.

Very likely the same change that breaks the test also breaks my application;
i.e. the relevant change occurred between 2.0.7 and 2.0.8.

Versions used by my application: dirmngr-1.0.1, gnupg-1.4.8, gnupg-2.0.7 resp.
gnupg-2.0.8 (this is the only difference between working and failing),
gpgme-1.1.6, libassuan-1.0.4, libgcrypt-1.4.0, libgpg-error-1.6, libksba-1.0.3,
pinentry-0.7.3, pth-2.0.7

Details

Version
2.0.8
perske set Version to 2.0.8.
perske added a subscriber: perske.
werner added a subscriber: werner.Mar 19 2008, 8:49 PM

Can you please enable debugging for gpgsm. Add these lines to gpgsm.conf

log-file /foo/bar/baz
debug 1025
verbose

and send that file by PM (wk at gnupg org)

werner claimed this task.
werner closed this task as Resolved.

The problem is a missing "de" at the end of a line in qualified.txt. Please add
it yourself similar to the other lines.