Add support for explicit_memset
AbandonedPublic

Authored by jukivili on Apr 28 2019, 8:35 AM.

Details

Reviewers
None
Summary
From: Jussi Kivilinna <jussi.kivilinna@iki.fi>

* configure.ac: Add function check for 'explicit_memset'.
* src/misc.c (_gcry_fast_wipememory, _gcry_fast_wipememory2): Use
explicit_memset if available.
--

GnuPG-bug-id: D476
Reported-by: <devnexen@gmail.com>
Signed-off-by: Jussi Kivilinna <jussi.kivilinna@iki.fi>
Test Plan

To be tested on system with explicit_memset

Diff Detail

Repository
rC libgcrypt
Lint
Lint Skipped
Unit
Unit Tests Skipped
jukivili created this revision.Apr 28 2019, 8:35 AM
jukivili edited the summary of this revision. (Show Details)
jukivili edited the summary of this revision. (Show Details)
jukivili abandoned this revision.May 1 2019, 3:22 PM

This change has been pushed to repository.