GPA crash on Ubuntu with "Unsupported certificate"
Closed, ResolvedPublic

Description

The GPA version in Ubuntu crashes, see
https://bugs.launchpad.net/ubuntu/+source/gpa/+bug/1381926.

Seqmentation fault, message "The GPGME library returned an unexpected error. The
error was:

Unsupported certificate

This is probably a bug in GPA."

As this makes GPA unusable on the most popular GNU/Linux Desktop distribution,
I think I file an upstream issue here.

bernhard set External Link to https://bugs.launchpad.net/ubuntu/+source/gpa/+bug/1381926.Nov 6 2014, 4:41 PM
bernhard added projects: gpa, Bug Report, Ubuntu.
bernhard set Version to 0.9.4.
bernhard added subscribers: werner, bernhard.
werner added a comment.Nov 7 2014, 8:03 AM

This is likely fixed in 0.9.5 release Sep 1.

It's not crashing for me with master but its not fixed.

I acidentally ran into this while checking out a windows crash and found the cause:
echo $GPG_AGENT_INFO /run/user/1000/keyring-Lvs93w/gpg:0:1

At least this was my problem and as "Ubuntu" is the platform it is likely that
this was the original problem.

I've commented in the launchpad report.

aheinecke changed Version from 0.9.4 to master.Nov 19 2014, 4:03 PM

0.9.6 will be release today, thus I close it.

GNOME--

werner closed this task as Resolved.Nov 21 2014, 9:37 AM
werner claimed this task.