libgcrypt: build fails on Gentoo/FreeBSD 10.0 or later (x86-fbsd)
Closed, ResolvedPublic

Description

The following message is displayed and fails to compile.

libtool: compile: i686-gentoo-freebsd10.1-gcc -DHAVE_CONFIG_H -I.
-I/var/tmp/portage/dev-libs/libgcrypt-1.6.3/work/libgcrypt-1.6.3/mpi -I..
-I../src -I/var/tmp/portage/dev-libs/libgcrypt-1.6.3/work/libgcrypt-1.6.3/src
-D_THREAD_SAFE -Wa,--noexecstack -O2 -march=i686 -pipe -c mpih-add1-asm.S -fPIC
-DPIC -o .libs/mpih-add1-asm.o
mpih-add1-asm.S: Assembler messages:
mpih-add1-asm.S:44: Error: alignment not a power of 2
mpih-add1-asm.S:79: Error: alignment not a power of 2
Makefile:596: recipe for target 'mpih-add1-asm.lo' failed
gmake[2]: * [mpih-add1-asm.lo] Error 1
gmake[2]:
* Waiting for unfinished jobs....
libtool: compile: i686-gentoo-freebsd10.1-gcc -DHAVE_CONFIG_H -I.
-I/var/tmp/portage/dev-libs/libgcrypt-1.6.3/work/libgcrypt-1.6.3/mpi -I..
-I../src -I/var/tmp/portage/dev-libs/libgcrypt-1.6.3/work/libgcrypt-1.6.3/src
-D_THREAD_SAFE -Wa,--noexecstack -O2 -march=i686 -pipe -c mpih-sub1-asm.S -fPIC
-DPIC -o .libs/mpih-sub1-asm.o
mpih-sub1-asm.S: Assembler messages:
mpih-sub1-asm.S:45: Error: alignment not a power of 2
mpih-sub1-asm.S:80: Error: alignment not a power of 2
Makefile:596: recipe for target 'mpih-sub1-asm.lo' failed
gmake[2]: *** [mpih-sub1-asm.lo] Error 1

I think caused by does not contain a regular expression for the freebsd10.0 in
mpi/config.links.
The attached patch to add it, and the successful compile.

nigoro set External Link to https://bugs.gentoo.org/show_bug.cgi?id=494740.May 9 2015, 1:19 PM
nigoro added a comment.May 9 2015, 1:32 PM

Probably, T1936 will a duplicate of this issue.
Create a new issue so I could not comment on the issue...

werner added a subscriber: werner.May 11 2015, 2:16 PM

[I granted you the User role (see https://bugs.gnupg.org)]

gniibe claimed this task.
gniibe added a subscriber: gniibe.

Thank you, patch applied to master and 1.6 branch.

Fixed in 1.6.4.

gniibe closed this task as Resolved.Sep 10 2015, 4:37 AM
gniibe removed a project: Testing.