tofu confused when keys are deleted from keyring
Closed, ResolvedPublic

Description

I had three keys that had userIDs matching one particular e-mail address. They
were stored in the tofu db's bindings table.

I deleted two of them (only one remained), and then i tried to encrypt mail to
that e-mail address. I got the tofu prompt asking me about all three keys.

This was confusing -- what were these mystery keys that were no longer in my
keyring? (it would have been more confusing if it had happened more than a few
hours after the deletion of those keys)

Details

Version
2.1.15
dkg set Version to 2.1.15.Oct 7 2016, 12:04 AM
dkg added projects: gnupg, Bug Report.
dkg added subscribers: dkg, neal.
neal added a comment.Dec 2 2016, 9:40 AM

This issue has also been reported in https://bugs.gnupg.org/gnupg/Issue2859

Werner replied there and I agree with his conclusion.

werner added a subscriber: werner.

Duplicate of T2859

werner closed this task as Resolved.Dec 2 2016, 10:04 AM