read/parse pubkeys in gpgme without importing
Closed, ResolvedPublic

Description

Jeroen Ooms asks:

Is there a way to let gpgme read/parse a (set of) keys in memory, without
actually importing it in the keyring? So suppose I have a file with an
armored set of keys like this:

  http://pgp.mit.edu/pks/lookup?op=get&search=jeroen+ooms

Can I parse this file in gpgme to print the name/email/fingerprints of the
pubkeys without actually importing into my keyring?

Werner replies:

Not yet. We need to add such a feature to gpgme.

Related Objects

neal set External Link to https://lists.gnupg.org/pipermail/gnupg-devel/2016-October/031918.html.
neal added subscribers: neal, werner.

I think this is a dup of T2819

That issue also contains a possible implementation. I'm not sure anymore why we
didn't push it I think it was because we were under release pressure and wanted
do look into this later.

werner closed this task as Resolved.
werner claimed this task.

Duplicate of T2819

I close this one. An implementation is already in master.