CRLs are not automatically loaded, when trying to send a mail to S/MIME recipient
Closed, ResolvedPublic

Description

Steps to Reproduce:

Have latest version of Kleoptra and GpgOL installed
Have one certifciate to sign and encrypt with and one to sign and encrypt to,
preferably from two different CAs
Enable S/MIME in GpgOL
Write Mail to the recepient, where you have the public certificate and trustchain of
Try to send mail
Choose the desired certificate
-> Error, that the mail can't be signed/encrpyted, because there is no valid CRL
object

Related Objects

werner added a subscriber: werner.Mar 6 2017, 12:43 PM

Which gpg4win version?
Does this work on the command line?

This was with gnupg 2.1.19 I think it's a duplicate of T2984 if the CRL
can't be loaded sending an S/MIME mail will fail.

I just tested it with gpg4win3.0.0-beta215

gpgsm -v --output Downloads\kitten.gpg --recipient jochen@intevation.de

Downloads\kitten.jpg

gpgsm: certificate #13/CN=Email CA 2013,O=Intevation GmbH,C=DE
gpgsm: Die CRL konnte nicht geprüft werden: Ungültiges CRL Objekt
gpgsm: Benutztes Gültigkeitsmodell: Schale
gpgsm: Hinweis: Verschlüsselung für `jochen@intevation.de' wird nicht

möglich sein: Ungültiges CRL Objekt

    gpgsm: Ungültiger Befehl (Es gibt keinen implizierten Befehl)

So the CRL file was not automatically pulled via console either.

bernhard renamed this task from crl are not automatically loaded, wen trying to send a mail to S/MIME recipient to CRLs are not automatically loaded, when trying to send a mail to S/MIME recipient.Nov 21 2017, 11:31 AM
bernhard updated the task description. (Show Details)
aheinecke closed this task as Resolved.Dec 6 2017, 2:29 PM
aheinecke claimed this task.

I just tested with intevation's CA on Windows and it works. It also worked with our test.ca in the base test before the 3.0.1 release. I think this is resolved.