GpgOL does not detect some OpenPGP NO-MIME mail body and attachments (multipart/related)
Closed, ResolvedPublic

Description

GpgOL from gpg4win-3.0.0-beta276/ does not detect some OpenPGP NO-MIME emails.
Thus it does not offer to decrypt them or the attachment.

It is assumed that this was due to some MIME content-type like text/html and multipart/related
where not searched for strings that indicate Open-PGP NO-MIME contents.

The original assumption was that GpgOL cannot handle base64 transfer encoded OpenPGP NO-MIME emails (some call it pgp/inline) messages. If such a mail arrives, the base64 encoded content of the message will be decrypted correctly by Outlook, but the gpg encrypted content won't be recognized by GpgOL, thus there will be no decryption of the original message.

To create such a mail, create a symmetric gpg encrypted text, base64 encode it. Write an EMail with some random content in KMail to yourself and encrypt and sign it. Sent it to yourself and save the sent mail as "mbox"-File. Delete the content of the mail and replace it with some symmetric gpg and base64 encoded text and modify the headers to

Content-Type: text/plain;
  charset="UTF-8"
Content-Transfer-Encoding: base64

(See https://tools.ietf.org/html/rfc2045#section-6.8 until https://tools.ietf.org/html/rfc2045#section-8)

as properties. Send this mail to your Outlook account, where GpgOL is installed. You will see the plain OpenPGP armored text, so the base64 decryption worked, but there will be no attempt to decrypt the message itself.

bernhard renamed this task from GpgOL should decrypt base64 encrypted PGP/INLINE messages to GpgOL should decrypt OpenPGP NO-MIME mails that come with a superfluous base64 transfer encoding.Aug 18 2017, 2:48 PM
bernhard updated the task description. (Show Details)
bernhard updated the task description. (Show Details)

- Contains an example *.mbox file. The Password to decrypt the text is "123".

I can't reproduce this issue. I've imported the attached mail with KMail and synced the folder to outlook.
GpgOL did decrypt the mail. It did not set the category correctly (These were two other bugs which I've fixed now) and displayed the wrong status information but decryption happened.

aheinecke closed this task as Resolved.Aug 21 2017, 1:45 PM

Talked with Jochen and tested this. Jochen's test forwarded the mail so he ran into T2854

The content-transfer encoding is transparent to us as we take the body from the OOM and let outlook handle the Content Transfer encoding.

But there was a bug that symmetric mails were not shown correctly this was fixed with:

0bbee29ac7054b9e570654cc358ad34c6c47db1f

bernhard renamed this task from GpgOL should decrypt OpenPGP NO-MIME mails that come with a superfluous base64 transfer encoding to GpgOL does not detect some OpenPGP NO-MIME mail body and attachments (multipart/related).Aug 23 2017, 9:01 AM
bernhard updated the task description. (Show Details)
bernhard updated the task description. (Show Details)Feb 6 2018, 9:12 AM