password display box remains hidden
Closed, ResolvedPublic

Description

Steps to reproduce

  1. Click on a file to sign & encrypt
  2. Fill out all the required fields
  3. Click on the "Sign/Encrypt" button
  4. "pinetry" pop up display box shows up but it remains hidden

Details

Version
3.0.0
boneymat created this task.Oct 19 2017, 8:38 PM
werner added a subscriber: werner.

Please look in the status bar of your desktop. You should see a (blinking) tab for the Pinentry. Unfortunately it is not always possible to get the Pinentry into the foreground and Windows will instead show it in the status bar.

PaulJ added a subscriber: PaulJ.Oct 31 2017, 9:32 PM

I am experiencing this error too and did not see any way to get to the Pinentry window. Only after killing the hung outlook process did the Pinentry window pop up.

aheinecke triaged this task as High priority.Nov 27 2017, 8:40 AM
aheinecke claimed this task.
aheinecke added a subscriber: aheinecke.

@PaulJ this sounds like a different problem. For you it does not show. In this report the pinentry open's in the background for file sign / encrypt.

I can reproduce this sometimes. I belive the Problem is that I added the "Popup" code from Pinentry to Kleopatra, too because I wanted to ensure that the Key Resolution from GpgOL opens in the foreground.

aheinecke closed this task as Resolved.Nov 30 2017, 10:32 AM

Fixed with https://cgit.kde.org/kleopatra.git/commit/?id=59ebe7da257131757f98e77912e39b3fd14ae3af Kleopatra was too agressive in the dialogs and always tried to stay on top. This makes sense for the Certificate selection dialog in GpgOL but not for the file dialog.