Issue with the Sign and Encrypt Explorer Context Menu option
Closed, ResolvedPublic

Description

Edit: Image order

I have fount that if i use the Sign and Encrypt function on a Directory, it successfully generates a FolderName.tar.pgp file.

However the file generated File does not include any of the folders/files that were in the Source Directory.
If i repeat the process, on a file it works fine... just not on directories.

Details

Version
3.0.0
Nillth created this task.Oct 27 2017, 2:43 AM
Nillth updated the task description. (Show Details)Oct 27 2017, 2:45 AM
cuenta added a subscriber: cuenta.Oct 27 2017, 10:38 AM

I have also experience the same bug and reported it on:
https://bugs.kde.org/show_bug.cgi?id=385390

Please vote and attach your screenshots for a prompt resolution.
Thanks

bernhard added a subscriber: bernhard.EditedOct 27 2017, 10:53 AM

Hi, thanks for the report.

I would be helpful if you could add the following information:

  • Which version of Windows did you encounter the problem with?
  • Do you know which last version worked for you (e.g. one of the betas or release candidates from https://files.gpg4win.org/Beta/
  • (Is it correct that you are using OpenPGP and file encryption/decryption works when using on single files?)
bernhard added a subscriber: emanuel.
bernhard added a subscriber: JochenSaalfeld.

Hi,
I was using Windows 7 Professional.
The last version that worked was gpg4win 2.3.4 (I didn't try any beta or rc), and encryption/decryption works fine for single files.

Regards

Hi,
I have tried this on Windows 10 (1511,1703,1709&RS4TP)
Gpg4win Version 3.0.0
Regards

aheinecke triaged this task as Unbreak Now! priority.
aheinecke added a subscriber: aheinecke.

Thanks for the report. This is indeed badly broken. I'll work on this now.
I can reproduce and also have a reproducable crash when trying to encrypt a special folder. This must be a recent regression because I tested this some months ago and it worked fine.

aheinecke changed the task status from Open to Testing.Nov 14 2017, 2:35 PM

Multiple bugs fixed here:

  1. Kleopatra did not report errors that happend during archiving. This could lead to broken archives because an error occured but GnuPG will happily encrypt a broken / empty archive) Fixed with: https://cgit.kde.org/kleopatra.git/commit/?id=0ebc73bb2248af0b6affefe0083287354dbd92a4
  2. The output of the archive command was not always passed completly to gnupg (again, broken or empty archives) Fixed with gpgme 56b27b21d5f8dd95b9d6415c5e98b821774f3093
  3. When extracting / decrypting the directory name was broken (T3500) and when a folder already existed it was not properly handled. Fixed with: https://cgit.kde.org/kleopatra.git/commit/?id=8435734848111f4133a3ad881ecfdcceef5b0af2
  1. was a missing commit overlooked in the switch to a KF5 based Kleopatra.
  2. Probably a bug that sneaked in in the KProcess / QProcess change during the Qt5 port.
  3. Not really sure when this broke. Probably in the gpgtar changes to have gpgtar do encryption.

I think it works now™

With the Release of Gpg4win 3.0.1 this error doesn't appear anymore for me while testing.

may @Nillth and/or @cuenta confirm this?

aheinecke closed this task as Resolved.Nov 28 2017, 3:55 PM

Setting this to resolved until we get reports to the contrary.

Sorry for the delay, been a busy busy couple of weeks..

I have just tested and can confirm that this is now resolved.
Encryption / Decryption of files is now working as expected.