Can't move emails from Inbox folder to other folders when GpgOL plugin is active
Closed, ResolvedPublic

Description

Emails received by Outlook, when GpgOL plugin is active, can not be moved to other folders.
Steps to reproduce:

  1. install GpgOL or make sure the GpgOL plugin is active
  2. send an email to self address or receive an email from any account
  3. open any encrypted email in the Inbox folder
  4. select a non-encrypted email in the message list panel
  5. try to move the non-encrypted email to another Outlook folder - Outlook will silently fail to move the email (no error message displayed, but the email is not moved)

Deactivating GpgOL plugin will fix the issue (messages can be moved without any error when GpgOL plugin is deactivated)
No other Outlook plugin was active during testing.

Log file attached.

Xv created this task.Dec 8 2017, 1:15 AM
Xv created this object in space S1 Public.
aheinecke triaged this task as Normal priority.Dec 8 2017, 6:28 AM
aheinecke added a subscriber: aheinecke.

I can't reproduce this with the above steps. It is sadly a known issue that moving crypto mails does not work as long as they are viewed. (T3459) But for me opening any unencrypted mail and moving it. Or first opening an encrypted mail and then moving an unencrypted mail works.

In your log I see:
22:28:37/13160/mailitem-events.cpp:Invoke: Write : 0306B6A0
22:28:37/13160/mailitem-events.cpp:Invoke: Canceling write event.
22:29:30/13160/application-events.cpp:Invoke: Unhandled Event: fb41
22:29:34/13160/mailitem-events.cpp:Invoke: Write : 0306B6A0
22:29:34/13160/mailitem-events.cpp:Invoke: Canceling write event.

The "Canceling write event" is what prevents the move (this is done for crypto mails to prevent decrypted data to be written to the storage). 0306B6A0 refers to "RE:Re: test1".

Is this reliably reproducible for you? Anything else special that you can think of? I've played around with opening the crypto mail in its own Window / own Explorer but "non-crypto" mails can be moved for me.

Or do you have multiselection with one crypto mail and another non-crypto mail?

aheinecke closed this task as Resolved.Jun 18 2018, 4:32 PM
aheinecke added a project: Duplicate.
aheinecke claimed this task.

I'm closing this as a duplicate of T3459