GnuPG, Scdaemon: Decryption fails - Missing Item in Object - No Secret Key
Closed, InvalidPublic

Description

I can't decrypt Messages sent to me by user "Mak" here.

They are encrypted to my smartcard RSA key. I get asked for the PIN but then SCD reports "Missing Item in Object"

gpg: public key decryption failed: Missing item in object
gpg: decryption failed: No secret key

This is particularly bad because in the GUI (Kleopatra / KMail) It just shows "No Secret Key" as the error. Which is at least a wrong error.

In jabber it was suggested that the problem might be that 3DES is used as the symmetric algorithm. How can I find out if that is true?

At least I think in that case the error message should be improved.

Details

Version
2.2.5-beta
aheinecke closed this task as Invalid.Jan 12 2018, 9:02 AM

Duplicate of T3576