Exchange without cache modus with Outlook 2010 might not show decrypted contents
Closed, ResolvedPublic

Description

Found this while trying to reproduce T3769
Log is different in that it decrypts / verifies here (in contrast to T3769 ) but does not update the body. The "Please wait while,..." message stays and is not removed.

Similar to prior reports of such behavior we see an unload event even though the message is still open.

I think the reason for this is not Exchange Online but that I was using two explorer Windows and switched between Mails while the decryption on the slow exchange folder was still running. This triggered an invalidate_ui while the parsing was active and that then triggered a write / unload just like in T3523

My fix for this is to block "invalidate_ui" while the parser is active. This might cause more delays in the sigstatus but if it helps gain stability this is a downside i can live with, as long as the sigstatus is correct after a decrypt / verify.

aheinecke closed this task as Resolved.Feb 15 2018, 7:50 AM

In my tests this is resolved with the commits mentioned here.